Synology DiskStation to Cisco Core Switch redundant setup with LACP

Table of contents

  1. Synology DiskStations
  2. Cabling between Core Switch and DiskStation
  3. Synology DiskStation LACP port configuration
  4. Cisco Switch port configuration
  5. Cisco Switch Etherchannel configuration
  6. Verify Etherchannel configuration

Synology DiskStations

In my network I have two Synology DiskStation with two Gigabit Ethernet ports connected to my Cisco core switch. The DiskStation and Cisco Switch provide LACP to increase throughput and redundancy. LACP is in Cisco terminology known as Etherchannel (where Port-Channel is the name of the virtual Interface).

Cabling between Core Switch and DiskStation

As shown in the drawing, I’m using two Cisco WS-C3750G switches which are stacked and act as a Core Switch. For redundancy I’m connecting the two Synology DiskStation with the first Gigabit Ethernet port on Stack member #1 and the second Gigabit Ethernet port on Stack member #2. This should cover typical cases like a Stack member of the Core Switch is powered down, one patch cable is disconnected or damaged, etc. The two patch cables and ports are then bundled into a LACP link on the DiskStation and a Port-Channel on the Cisco Switch Stack.

Cisco Core Switch to Synology DiskStation redundant cabling

Synology DiskStation LACP port configuration

To configure the LACP functionality on the Synology DiskStation, the two Gigabit Ethernet must be setup with Dynamic Link Aggregation (IEEE 802.3ad) as shown in the screenshot. Both physical Gigabit Ethernet ports are set up to 1000 Mbps/Full Duplex.

Synology DiskStation LACP port configuration

Cisco Switch port configuration

The first port of the Synology DiskStation is connected to Gi1/0/11 (Stack member #1) on the Cisco Core switch. The second port is then connected to Gi2/0/11, which is on Stack member #2. The speed and duplex settings are set to 1000/Full duplex and are forced with switchport nonegotiate to ensure the configured speed. The command channel-group puts the physical port into the virtual interface Port-Channel 11, the mode is set to active to start LACP packet negotiation.


    interface GigabitEthernet1/0/11
      description Synology-Diskstation-NAS1-Lan1
      switchport access vlan 1234
      switchport mode access
      switchport nonegotiate
      speed 1000
      duplex full
      channel-group 11 mode active
      spanning-tree portfast
    end

The second port of the Synology DiskStation is then connected to Gi2/0/11 which is on Cisco Stack member 2. The port configuration on the Core switch looks similar to port Gi1/0/11.


    interface GigabitEthernet2/0/12
      description Synology-Diskstation-NAS1-Lan2
      switchport access vlan 1234
      switchport mode access
      switchport nonegotiate
      speed 1000
      duplex full
      channel-group 11 mode active
      spanning-tree portfast
    end

Cisco Switch Etherchannel configuration

The Etherchannel (virtual interface Port-Channel) must have the same settings like provided on the physical ports participating in the Etherchannel. A configuration for this interface looks like:


    interface Port-channel11
      description Port-Channel Synology-Diskstation-NAS1
      switchport access vlan 1234
      switchport mode access
      switchport nonegotiate
      speed 1000
      duplex full
      spanning-tree portfast
    end

Verify Etherchannel configuration

To verify the Etherchannel the command show etherchannel summary can be used. The screenshot below shows that the two ports are bundled in a Port-Channel (P) and the ports are in use (U) and Layer2 (S) is used. Note also the protocol used for the Port-Channel is LACP.

Cisco switch: show etherchannel summary